博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
ZOJ 1151 Word Reversal反转单词 (string字符串处理)
阅读量:6473 次
发布时间:2019-06-23

本文共 1829 字,大约阅读时间需要 6 分钟。

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=151

For each list of words, output a line with each word reversed without changing the order of the words.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.

Output

For each test case, print the output on one line.

Sample Input

1

3

I am happy today
To be or not to be
I want to win the practice contest

Sample Output

I ma yppah yadot

oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc

翻译:
对于一串单词,直接把他们输出在一行上,要把每一个单词反转,但每一个单词的位置不要改变;
本程序包括多组測试数据;
输入数据的第一行是一个整数N,然后是一空行,后面跟着N个数据块,每一个数据块的格式在程序描写叙述中说明了,数据块中有一空行。
输出格式由N个输出块组成,每一个输出块之间有一空行;
输入描写叙述:
现给你多组測试数据,第一行是一个正整数,表示接下来測试数据的组数,每组測试占一行,包括一串单词,中间用一个空格隔开,每一个单词仅包括大小写字母;
输出描写叙述:
每组測试数据都打印在一行上;
代码:
#include <iostream>
#include <string>
#include <cstdio>
#include <algorithm>
using namespace std;
string s, t;
int n, cas, flag = 0;
char ss[1000];
int main()
{
    cin >> cas;
    while(cas--) {
        scanf("%d", &n);
        getchar();
        while(n--) {
            cin.getline(ss, 1000);
            s = ss;
            flag = 0;
            t.clear();
            for(int i=0; i<s.size(); i++) {
                if(s[i] != ' ' && i <= s.size()-1) {
                    t += s[i];
                }else {
                    reverse(t.begin(), t.end());
                    if(flag) cout << " ";
                    cout << t;
                    flag = 1;
                    t.clear();
                }
            }
            reverse(t.begin(), t.end());
            cout << " " << t << endl;
        }
        if(cas) cout << endl;
    }
    return 0;
}

转载地址:http://bopko.baihongyu.com/

你可能感兴趣的文章
NYOJ 97
查看>>
poj2378
查看>>
【译】SQL Server误区30日谈-Day12-TempDB的文件数和需要和CPU数目保持一致
查看>>
不为技术而技术:大型网站架构演化解析
查看>>
Java文件清单列表
查看>>
js url传值中文乱码之解决之道
查看>>
Atitit.获取某个服务 网络邻居列表 解决方案
查看>>
Trusty TEE
查看>>
[LeetCode] Reverse String 翻转字符串
查看>>
学习iOS【3】数组、词典和集合
查看>>
Hessian 原理分析--转
查看>>
转: 基于netty+ protobuf +spring + hibernate + jgroups开发的游戏服务端
查看>>
easyui传入map的数据前台展示出tree格式数据
查看>>
悲观的思考,乐观的生活.我们既需要思考的深度,也需要生活的温度!
查看>>
java.math.BigDecimal
查看>>
Vitamio中文API文档(4)—— VitamioInstaller
查看>>
河内之塔
查看>>
图像处理之基础---内窥镜医学图像增强
查看>>
yii框架常用url地址
查看>>
python3.4学习笔记(十六) windows下面安装easy_install和pip教程
查看>>